Demo

Probiere ClanSphere aus und teste daran herum. Demo

News - Details
Informationen zur ausgewählten Nachricht.

ClanSphere 2011.3 Patch 4
28.01.2013 um 05:10 Uhr - hajo ClanSphere Team
Kommentare (10)
English

We've made some small improvements to the version and update check in ClanSphere. Due to this older releases than 2011.3 Patch 4 won't get automatically notified about future updates (from now on). There are also some long awaited bugfixes and new external software updates included while those for the FCKEditor filebrowser also enhances its security. Further releases are not planned for now.

German

Wir haben den Versions- und Update-Check in ClanSphere etwas verbessern können. Dadurch werden ältere Releases als 2011.3 Patch 4 allerdings (ab jetzt) nicht mehr automatisch über neue Versionen benachrichtigt. Des Weiteren sind einige lang erwartete Bugfixes und Updates externer Software enthalten, wobei dass für den FCKEditor Dateibrowser sogar die Sicherheit dessen erhöht. Weitere Releases sind vorerst nicht geplant.

Changelog

-- Version and Update Check URLs have changed with this release
-- Earlier releases might not get notified about future changes

-> Added PHP GD Extension version to software overview (hajo)
-> Added rewrite support (Pretty URLs) for Lighttpd and Nginx (hajo)
-> Changed version check download target to show update packages (hajo)
-> Fixed CKEditor image filebrowser for admins in bbcode mode (hajo)
-> Fixed cs_html_img not able to handle basepath image urls (hajo)
-> Fixed files download page errors for non existing entries (hajo)
-> Fixed files listcat showing an empty list of subcategories (hajo)
-> Removed old cvs and svn version information from php files (hajo)
-> Updated CKEditor to 3.6.6
-> Updated CKEditor filebrowser to FCKEditor 2.6.9
-> Updated jQuery to 1.8.3
Link: Downloads

Kommentare: 10
Seite [1]
Blu3ye

25.09.2014

Ort: Albstadt
Beiträge: 171
# 1 - 28.01.2013 um 12:48 Uhr

Danke dafür
SHEG

24.01.2016

Ort: -
Beiträge: 24
# 2 - 28.01.2013 um 14:24 Uhr

Vielen Dank für die Fixes!

Nur ärgerlich, dass ich so viele PHP-Dateien bearbeitet habe. Da muss ich bei jedem Update vieles manuell prüfen Aber ist mein Problem
hajo ClanSphere Team

--

Ort: BarsbŁttel
Beiträge: 10035
# 3 - 28.01.2013 um 19:23 Uhr

bei vielen dateien haben sich dieses mal durch das entfernen der svn und cvs versionsdaten nur 1-2 unwichtige zeilen geändert. so etwas wird ab jetzt aber eigentlich nicht mehr wieder vorkommen. man sollte dies beim vergleichen mit einem DIFF tool zudem schnell erkennen können.
rockymania

18.01.2017

Ort: -
Beiträge: 38
# 4 - 28.01.2013 um 19:48 Uhr

Danke fürs Update

Ja, war gut zu erkennen, und bei mir war zum Glück keine Datei, mit die mit Codepaste oder wegen eines Mods verändert wurde, betroffen




Zuletzt editiert von rockymania, am 28.01.2013 um 19:48 Uhr (1x Editiert)
Dennisen

--

Ort: -
Beiträge: 387
# 5 - 28.01.2013 um 23:02 Uhr

Wie kann ich denn,
wenn ich die SVN-Daten und die Line-Endings von ein paar Versionen vorher selber rausmachen möchte, das in Batch machen?
Gibt's da ein Programm für?

Ich hab überall was geändert, sodass ich die Dateien nicht alle ersetzen will, aber ich glaube nicht, dass ihr jede Datei durchgegangen seid, daher gibt's ja eventuell eine Möglichkeit mit dem eigenen CSP Ordner einfach Batch alle File und Lineendings und die SVN-Infos zu korrigieren?
hajo ClanSphere Team

--

Ort: BarsbŁttel
Beiträge: 10035
# 6 - 28.01.2013 um 23:21 Uhr

bei mir lief das über ein suchen und ersetzen im editor durch mit nem regex, allerdings war der irgendwie fehlerhaft weshalb ich eine hand voll dateien manuell nachbearbeiten musste.

ansonsten kann man sich per git auch nur die wichtigen revisionen als patch ziehen, wenn man das repository lokal ausgecheckt hat und sich nen patch basteln möchte.
SHEG

24.01.2016

Ort: -
Beiträge: 24
# 7 - 29.01.2013 um 06:41 Uhr

Hab auch einfach die relevanten Dateien von Aptana vergleichen lassen, ging problemlos.

Die eigentliche Hürde sehe ich auch nur darin, die Dateien im Patch ausfindig zu machen, die man überprüfen sollte Da ist mir z.B. gestern erst der Fehler unterlaufen, dass ich die events/agenda.php übersehen habe, welche auch im Patch enthalten ist.

Hatte die agenda.php dahingehend angepasst, dass Termine, welche erst ab einem gewissen Zugriffs-Level sichtbar sein sollten, auch tatsächlich für niedrigere Level gar nicht erst angezeigt werden. Das liefert die Original-Datei nicht. Da werden erst einmal alle Termine angezeigt, unabhängig von der access_id.
Konnte aber ein Backup wieder aufspielen, war also kein Problem
assojan

21.12.2014

Ort: -
Beiträge: 7
# 8 - 31.01.2013 um 15:59 Uhr

Vielen Dank für dieses Update. Macht weiter so!

Clansphere rockt!
b3ndech0

22.02.2013

Ort: -
Beiträge: 30
# 9 - 08.02.2013 um 14:35 Uhr

dieser romiliang1972 spammt auch grad meine Seite zu. kotz
hajo ClanSphere Team

--

Ort: BarsbŁttel
Beiträge: 10035
# 10 - 09.02.2013 um 04:41 Uhr

verwaltung -> kommentare -> entfernen -> alle des benutzers entfernen

hat hier gerade gut geholfen und hab den mal deaktiviert. schreibt uns auch gern per kontakt oder pm usw. falls ihr auf der seite spam entdecken solltet oder ideen zu leicht umsetzbaren spam-verhinderungen habt.

Bitte Login benutzen, um Kommentare zu schreiben.